0
Release V26.7
Roadmap & Releases / Canary System Release Notes
Built on Windows Server 2019 Standard
MSBuild v17.0
MSI: Wix v1.14.2
Released on: September 21, 2026
If .NET Framework 4.7.1 or greater is not present on the system, it must be installed prior to installation.
SHA384 : 103B702C2D8BABB26B92AB7873E023438264D953C9206A58E821D43ECF23CC71367597DC12F559DD0331177663FD3597
SHA256 : 835D54CBFCDF186EF934838404858C96C03947933F6636D9610540AE304CF5BA
SHA512 : B3171E551725C1058407D15E4B8B4C5F6B0D1E72EBB627E71AE7A95AC09B85CC186A6E1F26DEC264A8C2BCE0CD887C516A0E4CB36E960D8836AB56841B617DC0
SHA1 : 93EC90E71A74FFCE7A79BC7EE64916ADCF0E2436
Features
Administrator
- Messages: Information to help determine if virus scanning software is running on the computer is logged at service start

- StoreAndForward: Better stream column sorting
- Calculations: Merge status into state column and add new icons for backfilling and waiting
Axiom
- Log kestrel messages as trace instead of error level
Diagnostic Health System
- API usage tags
- Garbage collection metrics tags
Historian
- Add Debug logging Messages for sequence number updates for troubleshooting model rebuilds
- Publisher: Configurable backfill date
StoreAndForward
- Instead of Pausing data streams when last file in DataSet is invalid, SaF retries to write once a minute until file is validated
- Improved Stream flushing prioritization for greater efficiency when flushing buffered data
All Services
- Log Debug Messages of service API calls when Debug Message logging is enabled
- Log Info/Warn Messages when call times exceed configured thresholds
Bug Fixes
Administrator
- Modifications to the Administrator's Configuration Settings page in the Client Endpoints section are lost when switching off the Admin tab
- Calculations: On the Jobs Page, expanded folders are not persisted when adding or clearing filters
- Calculations: When using DoesTagExist function in job with an Asset and no other items in the job, the job cannot be applied or saved
- Publisher: Durable stream label is not disabled when it should be because connection is enabled
- Publisher: Slow to load tile when several connections are configured
- Publisher: Creating a Publisher connection with nonexistent Views Host freezes tile and deletes the new connection
- Identity: Editing and then canceling on the edit overlay for an OpenID connect provider causes the Identity configuration changes banner to show
- StoreAndForward: Sessions with no tags are missing from the UI
- Historian: Admin client crashes opening a DataSet while the Admin client window is a small size
- Views: Delay recache setting does not apply until Views is manually restarted
- Views: Enhanced Audit Log message with no changes is logged when External Properties settings are changed
Axiom
- Event TrendGraph error when pinned event is configured
- Race condition might cause Axiom client disconnect message from improper use of CancellationTokenSource
- Fix performance bottleneck for very large Axiom Audit databases
- ValueTransform rejects {value} brace syntax accepted in version 23 with NCalc token error
- Does not load in nested iFrames
Calculations
- Circular references in a calculation job are not prevented from executing but do not work correctly
- When an event job with a tag subscription is on a tag for a DataSet that does not exist, it shows an asset error which can be misleading
Collectors
- OPC UA: Null reference exception can prevent reconnect from working
- OPC UA: Illegal timestamp errors are filling up the Message log when the UA server sends bad timestamps for many tags
- CSV: Crashes When Multiple Directory Configurations Share the Same DirectoryPath
- MQTT: Session Historian changes not saving to configuration database
Diagnostic Health System
- Administrator service logs error when Sender service is not running
Excel Add-In
- In AdHoc Events, Expression Base Path and Asset Type do not work when building the tag list for Start Trigger and End Trigger Expressions
- Locks up for about a minute then displays an unrelated error dialog if the user closes the authentication screen without authenticating
Historian
- Leaks memory when Annotations are read through the API
- Live data reads can cause a memory leak
- Can create a new hdb3 file when validation is turned off and last file is questionable
- If the Historian gets a timeout in its communication with the validator while a file is being validated, the file will not finish getting validated and the Historian will leak resources
- Validator consumes all CPU when trying to validate an HDB3 file with null (0x00) bytes in the middle of the file
- Views: CCIs can expire during a long-running call
- Views: InvalidOperationException can occur when reading raw data through the Web API
- Views: Last value calls with time extensions set to false that exceed 1 minute throw CCI error
- Views: Logs duplicate errors for some failed web API requests
- Views: A non-existent remote Historian configuration causes an error message to be logged every second after service restart
Install
- Migration: Fails if certificate cannot be read and user does not have permission to create self-signed certificate
Power BI Add-In
- Add-In does not appear in Power BI after install when user has OneDrive managing their Documents folder
Receiver
- Does not handle high session counts when proxying to StoreAndForward
StoreAndForward
- Race condition with multiple sessions writing to one DataSet can cause an exception
- Thread pool starvation is possible with many concurrent write requests
