Excel add-in Web Service Error
Hello
I've got to install Excel plugin on my laptop, but I'm unable to make it work. The issue I'm having is the following:

Configuration of settings: port 55321, HTTPS, Default timezone and authentication with API token (I've tried also without it).
Views is configured to use 55321 as the gRPC API (as default). The only difference compared to default installation is that the certificate for Views is one created by a CA.

Any ideas?
Thanks
10 replies
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This guy shows up about 80% of enterprises that I've seen. This is from an internal troubleshooting guide we have:
Root Cause:
The .NET Framework used by the add-in is not enforcing strong cryptographic protocols (e.g., TLS 1.2), which are required by the backend service.
Solution:
Update the registry to enable strong cryptography support in the .NET Framework:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
"SchUseStrongCrypto"=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319]
"SchUseStrongCrypto"=dword:00000001
Additional Notes:
After applying these changes, restart the system or at minimum restart Excel to apply the new settings.
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Thanks for the info! Does the Excel add-in require a specific .NET Framework installed? Or is it just about those registry entries being setup?
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BTW, forgot to confirm this worked (thanks a lot, looks like I'm not going through unknown challenges!!), however I'm concerned that we cannot do this in every user laptop that requires to use this setting. Wondering what Canary team would say about this.
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Hi ,
We don't have official documentation on this yet, but that is the recommended solution. You can read Microsoft's documentation concerning the SchUseStrongCrypto registry setting here: Transport Layer Security (TLS) best practices with .NET Framework | Microsoft Learn